Kahlar Publish time 2013-7-31 09:27:57

Unity engine - frame loss/audio hiccup

a wide spread known issue with Unity Engine 3.4/3.5 ...
frame loss and audio stutter.

the issue arises from multi threading bugs in Unity engine.

Akaneiro is plauged by this ... mainly on high end machines.

apparently there is a command line option that helps other games/devs:

-force-gfx-direct  will use the Unity 3.4 renderer in single threaded mode.
or
-force-gfx-st wil use the Unity 3.5 renderer in single thread mode.                                               

i have had no success in getting either of those to eliminate Akaneiro's frame/audio issues.

posting here hoping others may be more successful.

FOR THE DEVS: a C+ code that can be added to the game preventing need of command line options


[*]using UnityEditor;

[*]

[*]class ExtraSettings

[*]{

[*]    [MenuItem("Extra Settings/Enable MT Rendering")

[*]    static void EnableMTRendering()

[*]    {

[*]        UnityEditor.PlayerSettings.MTRendering = true;

[*]    }

[*]

[*]    [MenuItem("Extra Settings/Disable MT Rendering")

[*]    static void DisableMTRendering()

[*]    {

[*]        UnityEditor.PlayerSettings.MTRendering = false;

[*]    }

[*]}




FlightTribe Publish time 2013-7-31 15:22:15

Can't say I understand it myself but I'll forward the thread onto the tech team  :)

Nitromand Publish time 2013-7-31 17:35:20

FlightTribe replied at 2013-7-31 08:22 static/image/common/back.gif
Can't say I understand it myself but I'll forward the thread onto the tech team

;P

Thanks for adding this thread Kahlar. I've had sooooooo many issues with the Unity Engine. :(
Pages: [1]
View full version: Unity engine - frame loss/audio hiccup