SpicyWorld Forum

 Forgot password?
 Register
Search
View: 839|Reply: 4

Help! [Copy link]

Rank: 1

Post time 2012-12-23 09:24:05 |Show all posts
The beta is being extremley laggy, I can't usually click anywhere or click to move. Also, everything is slowed and I am not sure if it's my computer or the beta. Can anyone understand this/know what is going on?
Deseprate need of help, sorry!

Use magic Report

Rank: 7Rank: 7Rank: 7

Post time 2012-12-23 18:02:22 |Show all posts
Servers are in USA, I'm in Central Europe and I don't have such issues. If you're not located really far away from servers then it's probably your computer, or maybe your internet connection.

Use magic Report

Rank: 1

Post time 2012-12-23 21:10:11 |Show all posts
I live in Europe so I'm not sure. I guess it could be my internet. Any tips?

Use magic Report

Rank: 7Rank: 7Rank: 7

Post time 2012-12-23 22:00:44 |Show all posts
Check your connection speed @ http://www.speedtest.net/

That's mine if you want to compare:


If it's significantly lower then the internet connection might be the reason, if not - it's probably something with your PC. What browser do you use? Maybe try different ones.

Use magic Report

Rank: 1

Post time 2012-12-24 00:11:03 |Show all posts
This is mine:
http://www.speedtest.net/result/2390365496.png

Mine is considerably slower. I use Google Chrome. Thanks for the tips!

Use magic Report

You have to log in before you can reply Login | Register

Archiver|SpicyWorld

2021-4-11 08:53 GMT+8 , Processed in 0.016214 second(s), 10 queries .

To Top