SpicyWorld Forum

 Forgot password?
View: 649|Reply: 0

Stolen Remains - final boss BUG [Copy link]

Rank: 1

Post time 2014-1-12 20:04:06 |Show all posts
Edited by diathadevil at 2014-1-12 20:15

Soooo I was playing the map on Medium difficulty.
I was nearing the boss Naik The Great, and he came rushing towards me. So I moved away.
And just as I moved away, BAM. I fell down and died. Without even seeing any red numbers stating how much HP I lost or anything. He didn't even hit me either!!!
I tried going with a companion on that same difficulty. Still the same result, except the companion managed to kill him somehow and he ended up getting beaten.
I'm not sure if this is a bug everyone's been getting, but I sure have it. If anyone has any answers for this, please let me know.

EDIT: As I figured out, it's a glitch. I got my companion and used the caltrops to at least damage him and stop him from not chasing me. As he moves, he stops. Whenever I get near his stopped figure, he instantly kills me.

Use magic Report

You have to log in before you can reply Login | Register


2020-2-17 23:45 GMT+8 , Processed in 0.013098 second(s), 10 queries .

To Top